Posts

Adobe Flash Player Integer Overflow (Jan 22, 2015)

Adobe Flash is a multimedia platform that allows executing rich internet applications. Adobe Flash Player can also stream audio and video while functioning either from web browser or as a standalone application. It supports various data and multimedia formats like XML, JSON, SWF, MP3, FLV, GIF, etc. along with streaming protocols like HTTP, RTMP, etc.

Adobe Flash supports a scripting language called ActionScript; SWF file format is a binary format that adheres to an Adobe Flash Specification. ActionScript is used primarily for the development of websites and software targeting the Adobe Flash Player platform, used on Web pages in the form of embedded SWF files.

An integer overflow vulnerability exists in Adobe Flash Player. Specifically, the vulnerability is due to insufficient validation while handling ActionScript embedded in SWF files. A remote attacker can exploit this vulnerability by enticing a user to open a crafted SWF file. Successful exploitation could lead to arbitrary code execution in the security context of the logged-in user.

Dell SonicWALL has researched the vulnerability and released the following signature(s) to detect and block specific exploitation attempts targeting this vulnerability:

  • GAV 22144 “Malformed.swf.MP.132”

The vulnerability has been assigned as CVE-2014-0569.